Chat App with Firebase Part 1 – Setting Up The Project – Android Studio Tutorial



Socials:
►Instagram:
►Twitter:
►Facebook:

Hi, Im starting with new serie, I want to show you
how to create a chat app with firebase
In this part we will setting up the project
I hope you will enjoy this video.

/*
Android Studio, Android Developer, Android Development, Learn Code, Android App, Android Studio Tutorials, Mobile Developer, Java, Android Course, Android Training, Android Programming Tutorial for beginners,…

28 Comments

  1. Please use the latest versions of the libraries, respectively the firebase.

  2. When iam add firebase authentucation in my app, my build.gradle app add implementation
    'com.google.firebase:firebase-auth:16.0.1:15.0.0'

    its make my project can't build because
    "Failed to resolve: firebase-auth-15.0.0"

    can u help me? Thx

  3. Firebase authentication not connected this eror (Failed to resolve: firebase-auth-15.0.0 )

  4. How to use firebase without Real device…i mean genymotion , is this possible? plz tell me someone….

  5. How to use firebase without Real device…i mean genymotion , is this possible? plz tell me someone….

  6. How to use firebase without Real device…i mean genymotion , is this possible? plz tell me someone….

  7. How to use firebase without Real device…i mean genymotion , is this possible? plz tell me someone….

  8. How to use firebase without Real device…i mean genymotion , is this possible? plz tell me someone….

  9. Failed to resolve: firebase-auth-15.0.0
    he is giving me this error what should i do because it also not taking any email and password in registration without it

  10. //libraries we need now

    implementation 'com.android.support:support-v4:28.0.0'

    implementation 'com.google.firebase:firebase-core:16.0.6'

    implementation 'com.google.firebase:firebase-database:16.0.5'

    implementation 'com.google.firebase:firebase-auth:16.1.0'

    implementation 'com.android.support:cardview-v7:28.0.0'

    implementation 'com.rengwuxian.materialedittext:library:2.1.4'

    implementation 'com.android.support:design:28.0.0'
    ///
    dependencies {
    classpath 'com.google.gms:google-services:4.2.0'}

  11. I really love chatroom app where I can meet new people. A lot of chatroom app on Google play is not free. Sometime u need to buy coins or gold n is not
    good. Kod dev I'll be grateful if u can teach me how to build it.
    First fragment should be list of chatrooms.
    Second fragment should be recent chatrooms u joined.
    Third fragment should be where user can create their own public chatroom n search.
    Forth should be user favorite chatroom.
    Similar to mocospace chat rooms

  12. please help me for this error????

    Could not get unknown property '' for DefaultExternalModuleDependency{group='com.rengwuxian.materialedittext', name='library', version='2.1.4', configuration='default'} of type org.gradle.api.internal.artifacts.dependencies.DefaultExternalModuleDependency.

  13. (Failed to resolve: firebase-auth-15.0.0) error occurring……

    dependencies {

    classpath 'com.android.tools.build:gradle:3.2.1'

    classpath 'com.google.gms:google-services:4.2.0'
    }

    and ……

    ( implementation 'com.google.firebase:firebase-auth:16.0.1:15.0.0' ) and …..

    (implementation 'com.android.support:support-v4:27.1.1'

    implementation 'com.android.support:design:27.1.1'

    implementation 'com.google.firebase:firebase-auth:16.1.0'

    implementation 'com.google.firebase:firebase-database:16.0.5'

    implementation 'com.google.firebase:firebase-core:16.0.6'

    implementation 'com.android.support:cardview-v7:27.1.1'

    implementation 'com.rengwuxian.materialedittext:library:2.1.4')

    these are implemented how to fix it?

  14. I appreciate the time and effort you spent for this tutorial. However your coding style needs to be improved. I strongly recommend you to read Clean Code book, before proceeding with next tutorial. This will help you improve your coding skills and will prevent others from writing bad code. Thank you!

  15. Just a question if i will set firebase rules to authenticatdd only read write then how people will read conversation?

  16. //libraries we need for now
    implementation 'com.android.support:support-v4:27.1.1'
    implementation 'com.android.support:design:27.1.1'
    implementation 'com.google.firebase:firebase-auth:16.1.0'
    implementation 'com.google.firebase:firebase-database:16.0.5'
    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.android.support:cardview-v7:27.1.1'
    implementation 'com.rengwuxian.materialedittext:library:2.1.4'

  17. Problem with Authentication app this error – Failed to resolve: firebase-auth-15.0.0

    libraries –

    implementation 'com.android.support:support-v4:27.1.1'

    implementation 'com.android.support:design:27.1.1'

    implementation 'com.google.firebase:firebase-auth:16.1.0'

    implementation 'com.google.firebase:firebase-database:16.0.5'
    implementation 'com.google.firebase:firebase-storage:16.0.5'

    implementation 'com.android.support:cardview-v7:27.1.1'
    implementation 'com.rengwuxian.materialedittext:library:2.1.4

Leave a Reply

Your email address will not be published. Required fields are marked *